<!DOCTYPE html>
<!--[if IE 6]>
<html id="ie6" lang="en-US">
<![endif]-->
<!--[if IE 7]>
<html id="ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html id="ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US">
<!--<![endif]-->
<head>
	<meta charset="UTF-8" />
			
	<meta http-equiv="X-UA-Compatible" content="IE=edge">
	<link rel="pingback" href="https://pasadenaweekly.com/xmlrpc.php" />

		<!--[if lt IE 9]>
	<script src="https://pasadenaweekly.com/wp-content/themes/Extra/scripts/ext/html5.js" type="text/javascript"></script>
	<![endif]-->

	<script type="text/javascript">
		document.documentElement.className = 'js';
	</script>

	<script>var et_site_url='https://pasadenaweekly.com';var et_post_id='115254';function et_core_page_resource_fallback(a,b){"undefined"===typeof b&&(b=a.sheet.cssRules&&0===a.sheet.cssRules.length);b&&(a.onerror=null,a.onload=null,a.href?a.href=et_site_url+"/?et_core_page_resource="+a.id+et_post_id:a.src&&(a.src=et_site_url+"/?et_core_page_resource="+a.id+et_post_id))}
</script><title>TRAX 06.11.20 - Pasadena Weekly</title>

<!-- This site is optimized with the Yoast SEO plugin v12.4 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://pasadenaweekly.com/trax-06-11-20/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="TRAX 06.11.20 - Pasadena Weekly" />
<meta property="og:description" content="WYATT WADDELL, Fight! (Rosebud Allday): **** In the expanding parade of raw songs emerging from historic protests marching across the country and globe, this soulful Chicagoan’s single stands out with its exuberant faith and focus. A smartly edited video swiftly garnered media attention and the song, released last week to digital platforms, piques curiosity about &hellip;" />
<meta property="og:url" content="https://pasadenaweekly.com/trax-06-11-20/" />
<meta property="og:site_name" content="Pasadena Weekly" />
<meta property="article:publisher" content="https://www.facebook.com/PasadenaWeekly" />
<meta property="article:section" content="Trax" />
<meta property="article:published_time" content="2020-06-11T06:06:58-07:00" />
<meta property="article:modified_time" content="2020-06-11T16:27:56-07:00" />
<meta property="og:updated_time" content="2020-06-11T16:27:56-07:00" />
<meta property="og:image" content="https://i2.wp.com/pasadenaweekly.com/wp-content/uploads/2020/06/Trax_web_061120.jpg?fit=800%2C533&#038;ssl=1" />
<meta property="og:image:secure_url" content="https://i2.wp.com/pasadenaweekly.com/wp-content/uploads/2020/06/Trax_web_061120.jpg?fit=800%2C533&#038;ssl=1" />
<meta property="og:image:width" content="800" />
<meta property="og:image:height" content="533" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="WYATT WADDELL, Fight! (Rosebud Allday): **** In the expanding parade of raw songs emerging from historic protests marching across the country and globe, this soulful Chicagoan’s single stands out with its exuberant faith and focus. A smartly edited video swiftly garnered media attention and the song, released last week to digital platforms, piques curiosity about [&hellip;]" />
<meta name="twitter:title" content="TRAX 06.11.20 - Pasadena Weekly" />
<meta name="twitter:site" content="@pasadenaweekly" />
<meta name="twitter:image" content="https://i2.wp.com/pasadenaweekly.com/wp-content/uploads/2020/06/Trax_web_061120.jpg?fit=800%2C533&#038;ssl=1" />
<meta name="twitter:creator" content="@pasadenaweekly" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://pasadenaweekly.com/#website","url":"https://pasadenaweekly.com/","name":"Pasadena Weekly","potentialAction":{"@type":"SearchAction","target":"https://pasadenaweekly.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://pasadenaweekly.com/trax-06-11-20/#primaryimage","url":"https://i2.wp.com/pasadenaweekly.com/wp-content/uploads/2020/06/Trax_web_061120.jpg?fit=800%2C533&ssl=1","width":800,"height":533},{"@type":"WebPage","@id":"https://pasadenaweekly.com/trax-06-11-20/#webpage","url":"https://pasadenaweekly.com/trax-06-11-20/","inLanguage":"en-US","name":"TRAX 06.11.20 - Pasadena Weekly","isPartOf":{"@id":"https://pasadenaweekly.com/#website"},"primaryImageOfPage":{"@id":"https://pasadenaweekly.com/trax-06-11-20/#primaryimage"},"datePublished":"2020-06-11T06:06:58-07:00","dateModified":"2020-06-11T16:27:56-07:00","author":{"@id":"https://pasadenaweekly.com/#/schema/person/eb5ab3ed32c5390e22d74f860c23ba45"}},{"@type":["Person"],"@id":"https://pasadenaweekly.com/#/schema/person/eb5ab3ed32c5390e22d74f860c23ba45","name":"Bliss Bowen","sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Pasadena Weekly &raquo; Feed" href="https://pasadenaweekly.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Pasadena Weekly &raquo; Comments Feed" href="https://pasadenaweekly.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Pasadena Weekly &raquo; TRAX 06.11.20 Comments Feed" href="https://pasadenaweekly.com/trax-06-11-20/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/pasadenaweekly.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.1"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<meta content="Extra Child v.2.0.4.1474500135" name="generator"/><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='ai1ec_style-css'  href='//pasadenaweekly.com/wp-content/plugins/all-in-one-event-calendar/cache/d47f3cc0_ai1ec_parsed_css.css?ver=2.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://pasadenaweekly.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='chld_thm_cfg_parent-css'  href='https://pasadenaweekly.com/wp-content/themes/Extra/style.css?ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='extra-style-css'  href='https://pasadenaweekly.com/wp-content/themes/Extra-child/style.css?ver=2.20.2' type='text/css' media='all' />
<link rel='stylesheet' id='chld_thm_cfg_separate-css'  href='https://pasadenaweekly.com/wp-content/themes/Extra-child/ctc-style.css?ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://pasadenaweekly.com/wp-includes/css/dashicons.min.css?ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://pasadenaweekly.com/wp-content/plugins/jetpack/css/jetpack.css?ver=7.1.1' type='text/css' media='all' />
<script type='text/javascript' src='https://pasadenaweekly.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://pasadenaweekly.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var dfp_ad_object = [{"google_ad_script_name":"google_ad_js","script_name":null,"account_id":"\/1068269\/","asynch":true,"dir_uri":null,"positions":[{"post_id":114165,"title":"Leaderboard Top","ad_name":"6099645","position_tag":"ad_pos_6099645","sizes":[728,90],"out_of_page":true,"targeting":[]}],"page_targeting":{"Page":["trax-06-11-20"],"Category":["Trax"],"Tag":""}}];
/* ]]> */
</script>
<script type='text/javascript' src='https://pasadenaweekly.com/wp-content/plugins/dfp-ads/assets/js/google-ads.min.js?ver=5.4.1'></script>
<script type='text/javascript' src='https://pasadenaweekly.com/wp-content/plugins/dfp-ads/assets/js/dfp-ads.min.js?ver=5.4.1'></script>
<link rel='https://api.w.org/' href='https://pasadenaweekly.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://pasadenaweekly.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://pasadenaweekly.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://wp.me/p9dwQ8-tYW' />
<link rel="alternate" type="application/json+oembed" href="https://pasadenaweekly.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fpasadenaweekly.com%2Ftrax-06-11-20%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://pasadenaweekly.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fpasadenaweekly.com%2Ftrax-06-11-20%2F&#038;format=xml" />

<!-- This site is using AdRotate v5.6.2 to display their advertisements - https://ajdg.solutions/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->

<script type='text/javascript' data-cfasync='false'>var _mmunch = {'front': false, 'page': false, 'post': false, 'category': false, 'author': false, 'search': false, 'attachment': false, 'tag': false};_mmunch['post'] = true; _mmunch['postData'] = {"ID":115254,"post_name":"trax-06-11-20","post_title":"TRAX 06.11.20","post_type":"post","post_author":"1071","post_status":"publish"}; _mmunch['postCategories'] = [{"term_id":385,"name":"Trax","slug":"trax","term_group":0,"term_taxonomy_id":385,"taxonomy":"category","description":"","parent":344,"count":113,"filter":"raw","cat_ID":385,"category_count":113,"category_description":"","cat_name":"Trax","category_nicename":"trax","category_parent":344}]; _mmunch['postTags'] = false; _mmunch['postAuthor'] = {"name":"Bliss Bowen","ID":1071};</script><script data-cfasync="false" src="//a.mailmunch.co/app/v1/site.js" id="mailmunch-script" data-plugin="cc_mm" data-mailmunch-site-id="426394" async></script><meta name="generator" content="Custom Login v3.2.9" />

<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=1" /><!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-21325522-7"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-21325522-7');
</script>

<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>

<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/1068269/Half_Page', [300, 600], 'div-gpt-ad-1509569004297-0').addService(googletag.pubads());
    googletag.defineSlot('/1068269/LB2', [728, 90], 'div-gpt-ad-1509569004297-1').addService(googletag.pubads());
    googletag.defineSlot('/1068269/LB3', [728, 90], 'div-gpt-ad-1509569004297-2').addService(googletag.pubads());
    googletag.defineSlot('/1068269/Leaderboard', [728, 90], 'div-gpt-ad-1509569004297-3').addService(googletag.pubads());
    googletag.defineSlot('/1068269/SQ2', [300, 250], 'div-gpt-ad-1509569004297-4').addService(googletag.pubads());
    googletag.defineSlot('/1068269/SQ3', [300, 250], 'div-gpt-ad-1509569004297-5').addService(googletag.pubads());
    googletag.defineSlot('/1068269/Square', [300, 250], 'div-gpt-ad-1509569004297-6').addService(googletag.pubads());
    googletag.defineSlot('/1068269/BOB', [728, 90], 'div-gpt-ad-1509569004297-7').addService(googletag.pubads());
    googletag.defineSlot('/1068269/BOB2', [160, 600], 'div-gpt-ad-1509569004297-8').addService(googletag.pubads());
    googletag.defineSlot('/1068269/DiningLB', [728, 90], 'div-gpt-ad-1509569004297-9').addService(googletag.pubads());
    googletag.defineSlot('/1068269/Half_Page02', [300, 600], 'div-gpt-ad-1541632465426-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script><link rel="icon" href="https://i2.wp.com/pasadenaweekly.com/wp-content/uploads/2016/12/cropped-jgpw-512-px-copy.png?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i2.wp.com/pasadenaweekly.com/wp-content/uploads/2016/12/cropped-jgpw-512-px-copy.png?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon" href="https://i2.wp.com/pasadenaweekly.com/wp-content/uploads/2016/12/cropped-jgpw-512-px-copy.png?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i2.wp.com/pasadenaweekly.com/wp-content/uploads/2016/12/cropped-jgpw-512-px-copy.png?fit=270%2C270&#038;ssl=1" />
<link rel="stylesheet" id="et-extra-customizer-global-cached-inline-styles" href="https://pasadenaweekly.com/wp-content/cache/et/global/et-extra-customizer-global-159189310633.min.css" onerror="et_core_page_resource_fallback(this, true)" onload="et_core_page_resource_fallback(this)" /></head>
<body class="post-template-default single single-post postid-115254 single-format-standard et_extra et_fullwidth_nav et_fullwidth_secondary_nav et_fixed_nav et_smooth_scroll boxed_layout et_pb_gutters2 et_primary_nav_dropdown_animation_scaleInCenter et_secondary_nav_dropdown_animation_scaleInCenter with_sidebar with_sidebar_right et_includes_sidebar et-db et_minified_js et_minified_css">
	<div id="page-container" class="page-container">
				<!-- Header -->
		<header class="header left-right">
						<!-- #top-header --><br><div class="g g-8"><div class="g-single a-66"><center><a class="gofollow" data-track="NjYsOCwxLDYw" href="www.fuller.edu/fpfs"target="_blank"><img src="https://i2.wp.com/pasadenaweekly.com/wp-content/uploads/2020/04/Fuller_042320_728x90.png?ssl=1" /></a></center></div></div>			<div id="top-header" style="">
				<div class="container">

					<!-- Secondary Nav -->
											<div id="et-secondary-nav" class="et-trending">
						
							<!-- ET Trending -->
							<div id="et-trending">

								<!-- ET Trending Button -->
								<a id="et-trending-button" href="#" title="">
									<span></span>
									<span></span>
									<span></span>
								</a>

								<!-- ET Trending Label -->
								<h4 id="et-trending-label">
									TRENDING:								</h4>

								<!-- ET Trending Post Loop -->
								<div id='et-trending-container'>
																											<div id="et-trending-post-101112" class="et-trending-post et-trending-latest">
											<a href="https://pasadenaweekly.com/call-name-may-oscar-contender-rotten-core/">‘Call Me By Your Name’ may be an Oscar contender, but i...</a>
										</div>
																			<div id="et-trending-post-103423" class="et-trending-post">
											<a href="https://pasadenaweekly.com/former-police-chief-defends-against-recent-attack-on-departments-integrity/">Former police chief defends against recent attack on de...</a>
										</div>
																			<div id="et-trending-post-103307" class="et-trending-post">
											<a href="https://pasadenaweekly.com/owners-of-websters-in-altadena-have-earned-the-benefit-of-the-doubt-in-trademark-dispute/">Owners of Webster’s in Altadena have earned the benefit...</a>
										</div>
																									</div>
							</div>
							<ul id="et-secondary-menu" class="nav"><li id="menu-item-89365" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-89365"><a href="https://pasadenaweekly.com/about/">About PW</a></li>
<li id="menu-item-89994" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-89994"><a href="https://pasadenaweekly.wpengine.com/wp-login.php?action=register">Register for our Website</a></li>
<li id="menu-item-89995" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-89995"><a href="https://pasadenaweekly.wpengine.com/wp-login.php">Login to our Website</a></li>
<li id="menu-item-89383" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-89383"><a href="mailto:jon@pasadenaweekly.com">Feedback!</a></li>
<li id="menu-item-89367" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-89367"><a href="https://pasadenaweekly.com/contact/">Contact Us</a></li>
<li id="menu-item-89368" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-89368"><a href="https://pasadenaweekly.com/advertising/">Advertising</a></li>
<li id="menu-item-89370" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-89370"><a href="https://pasadenaweekly.com/advertising/legals/">Legal Advertising</a></li>
<li id="menu-item-90013" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-90013"><a href="https://pasadenaweekly.com/pw-distribution-locations/">Where to Find Pasadena Weekly</a></li>
<li id="menu-item-89382" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-89382"><a href="mailto:kevinu@pasadenaweekly.com">Send a Letter to the Editor</a></li>
<li id="menu-item-89373" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-89373"><a href="http://www.vcreporter.com">Ventura County Reporter</a></li>
<li id="menu-item-89374" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-89374"><a href="http://sdcitybeat.com">San Diego CityBeat</a></li>
<li id="menu-item-89375" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-89375"><a href="http://argonautnews.com">The Argonaut</a></li>
<li id="menu-item-89376" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-89376"><a href="http://lifeafter50.com">Life After 50</a></li>
<li id="menu-item-89377" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-89377"><a href="http://ventanamonthly.com">Ventana Monthly</a></li>
<li id="menu-item-89378" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-89378"><a href="http://arroyomonthly.com">Arroyo</a></li>
<li id="menu-item-89379" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-89379"><a href="http://playavistadirect.com">Playa Vista Direct</a></li>
<li id="menu-item-89380" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-89380"><a href="http://www.ireadculture.com">Culture</a></li>
<li id="menu-item-89366" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-89366"><a href="https://pasadenaweekly.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-90762" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-90762"><a href="https://pasadenaweekly.com/careers/">Careers</a></li>
<li id="menu-item-89401" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-89401"><a href="https://www.youtube.com/watch?v=oHg5SJYRHA0">Surprise!</a></li>
<li id="menu-item-101946" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-101946"><a href="https://pasadenaweekly.com/category/specialissues/education-guide/">Schools</a></li>
</ul>
												</div>
					
					<!-- #et-info -->
					<div id="et-info">

						
						<!-- .et-extra-social-icons -->
						<ul class="et-extra-social-icons" style="">
																																														<li class="et-extra-social-icon facebook">
									<a href="https://www.facebook.com/PasadenaWeekly" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-facebook"></a>
								</li>
																																															<li class="et-extra-social-icon twitter">
									<a href="https://twitter.com/pasadenaweekly" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-twitter"></a>
								</li>
																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																		</ul>
						
						<!-- .et-top-search -->
												<div class="et-top-search" style="">
							<form role="search" class="et-search-form" method="get" action="https://pasadenaweekly.com/">
			<input type="search" class="et-search-field" placeholder="Search" value="" name="s" title="Search for:" />
			<button class="et-search-submit"></button>
		</form>						</div>
						
						<!-- cart -->
											</div>
				</div><!-- /.container -->
			</div><!-- /#top-header -->

			
			<!-- Main Header -->
			<div id="main-header-wrapper">
				<div id="main-header" data-fixed-height="60">
					<div class="container">
					<!-- ET Ad -->
						
						
						<!-- Logo -->
						<a class="logo" href="https://pasadenaweekly.com/" data-fixed-height="100">
							<img src="https://pasadenaweekly.wpengine.com/wp-content/uploads/2016/10/PW_Web_logoNEW2.jpg" alt="Pasadena Weekly" id="logo" />
						</a>

						
						<!-- ET Navigation -->
						<div id="et-navigation" class="">
							<ul id="et-menu" class="nav"><li id="menu-item-89331" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-89331"><a href="https://pasadenaweekly.wpengine.com">Home</a></li>
<li id="menu-item-89332" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-89332"><a href="https://pasadenaweekly.com/category/news/">News</a>
<ul class="sub-menu">
	<li id="menu-item-89333" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-89333"><a href="https://pasadenaweekly.com/category/news/feature-stories/">Feature Stories</a></li>
	<li id="menu-item-89337" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-89337"><a href="https://pasadenaweekly.com/category/news/news-briefs/">News Briefs</a></li>
	<li id="menu-item-89334" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-89334"><a href="https://pasadenaweekly.com/category/news/news-features/">News Features</a></li>
	<li id="menu-item-89335" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-89335"><a href="https://pasadenaweekly.com/category/news/web-exclusives/">Web Exclusives</a></li>
	<li id="menu-item-89336" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-89336"><a href="https://pasadenaweekly.com/category/news/the-count/">The Count</a></li>
</ul>
</li>
<li id="menu-item-89341" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-89341"><a href="https://pasadenaweekly.com/category/opinion/">Opinion</a>
<ul class="sub-menu">
	<li id="menu-item-89340" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-89340"><a href="https://pasadenaweekly.com/category/opinion/letters/">Letters</a></li>
	<li id="menu-item-89339" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-89339"><a href="https://pasadenaweekly.com/category/opinion/guest-opinions/">Guest Opinions</a></li>
	<li id="menu-item-89338" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-89338"><a href="https://pasadenaweekly.com/category/opinion/editorials/">Editorials</a></li>
	<li id="menu-item-94062" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-94062"><a href="https://pasadenaweekly.com/category/opinion/cartoons/">Editorial Cartoons</a></li>
</ul>
</li>
<li id="menu-item-89342" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-89342"><a href="https://pasadenaweekly.com/category/arts/">Arts</a>
<ul class="sub-menu">
	<li id="menu-item-89344" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-89344"><a href="https://pasadenaweekly.com/category/arts/arts-features/">Arts Features</a></li>
</ul>
</li>
<li id="menu-item-89346" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-89346"><a href="https://pasadenaweekly.com/category/life/">Life</a>
<ul class="sub-menu">
	<li id="menu-item-89349" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-89349"><a href="https://pasadenaweekly.com/category/life/well-being/">Well Being</a></li>
	<li id="menu-item-89351" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-89351"><a href="https://pasadenaweekly.com/category/life/homesales/">Home Sales</a></li>
	<li id="menu-item-89347" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-89347"><a href="https://pasadenaweekly.com/category/life/bulletinboard/">Bulletin Board</a></li>
	<li id="menu-item-89348" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-89348"><a href="https://pasadenaweekly.com/category/life/outdoors/">Outdoors</a></li>
	<li id="menu-item-89350" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-89350"><a href="https://pasadenaweekly.com/category/life/wheels/">Wheels</a></li>
</ul>
</li>
<li id="menu-item-89352" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-89352"><a href="https://pasadenaweekly.com/category/music/">Music</a>
<ul class="sub-menu">
	<li id="menu-item-89354" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-89354"><a href="https://pasadenaweekly.com/category/music/trax/">Trax</a></li>
	<li id="menu-item-89353" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-89353"><a href="https://pasadenaweekly.com/category/music/music-notes/">Music Notes</a></li>
</ul>
</li>
<li id="menu-item-89355" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-89355"><a href="https://pasadenaweekly.com/category/film/">Film</a>
<ul class="sub-menu">
	<li id="menu-item-89356" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-89356"><a href="https://pasadenaweekly.com/category/film/film-reviews/">Film Reviews</a></li>
	<li id="menu-item-89357" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-89357"><a href="https://pasadenaweekly.com/category/film/flickfinder/">Flick Finder</a></li>
</ul>
</li>
<li id="menu-item-89359" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-89359"><a href="https://pasadenaweekly.com/category/dining/">Dining</a></li>
<li id="menu-item-89841" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-89841"><a href="https://pasadenaweekly.com/calendar-2/">Calendar</a>
<ul class="sub-menu">
	<li id="menu-item-89360" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-89360"><a href="https://pasadenaweekly.com/category/calendar/prime-picks/">Prime Picks</a></li>
	<li id="menu-item-89371" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-89371"><a href="https://pasadenaweekly.com/calendar-2/">Online Calendar</a></li>
	<li id="menu-item-89343" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-89343"><a href="https://pasadenaweekly.com/category/calendar/8-days/">8 Days</a></li>
	<li id="menu-item-89345" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-89345"><a href="https://pasadenaweekly.com/category/calendar/get-your-own/">Get Your Own</a></li>
</ul>
</li>
<li id="menu-item-89361" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-89361"><a href="https://pasadenaweekly.com/category/specialissues/">Specials</a>
<ul class="sub-menu">
	<li id="menu-item-114228" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-114228"><a href="https://pasadenaweekly.com/digital-editions/">Digital Editions</a></li>
	<li id="menu-item-112913" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-112913"><a href="https://pasadenaweekly.com/category/specialissues/35th-anniversary/">35th Anniversary</a></li>
	<li id="menu-item-92001" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92001"><a href="https://pasadenaweekly.com/category/specialissues/best-of-pasadena/">Best of Pasadena</a></li>
	<li id="menu-item-92003" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92003"><a href="https://pasadenaweekly.com/category/specialissues/education-guide/">Education &#038; Enrichment</a></li>
	<li id="menu-item-91997" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-91997"><a href="https://pasadenaweekly.com/category/specialissues/summer-guide/">Summer Guide</a></li>
	<li id="menu-item-92005" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92005"><a href="https://pasadenaweekly.com/category/specialissues/happy-birthday-pasadena/">Happy Birthday Pasadena</a></li>
	<li id="menu-item-92002" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92002"><a href="https://pasadenaweekly.com/category/specialissues/dining-guide/">Eat Drink Play</a></li>
	<li id="menu-item-92004" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92004"><a href="https://pasadenaweekly.com/category/specialissues/fall-arts/">Fall Arts</a></li>
	<li id="menu-item-92000" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92000"><a href="https://pasadenaweekly.com/category/specialissues/back-to-school/">Back to School</a></li>
	<li id="menu-item-92007" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92007"><a href="https://pasadenaweekly.com/category/specialissues/holiday-guide/">Holiday Guide</a></li>
	<li id="menu-item-91999" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-91999"><a href="https://pasadenaweekly.com/category/specialissues/welcome-to-pasadena/">Welcome To Pasadena</a></li>
	<li id="menu-item-91998" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-91998"><a href="https://pasadenaweekly.com/category/specialissues/wedding-guide/">Wedding Guide</a></li>
	<li id="menu-item-92006" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92006"><a href="https://pasadenaweekly.com/category/specialissues/health-connection/">Health Connection</a></li>
</ul>
</li>
</ul>							<div id="et-mobile-navigation">
			<span class="show-menu">
				<div class="show-menu-button">
					<span></span>
					<span></span>
					<span></span>
				</div>
				<p>Select Page</p>
			</span>
			<nav>
			</nav>
		</div> <!-- /#et-mobile-navigation -->						</div><!-- /#et-navigation -->
					</div><!-- /.container -->
				</div><!-- /#main-header -->
			</div><!-- /#main-header-wrapper -->

		</header>

				<div id="main-content">
		<div class="container">
		<div id="content-area" class="clearfix">
			<div class="et_pb_extra_column_main">
				<!-- /1068269/Leaderboard -->
<div id="div-gpt-ad-1509569004297-3" style="height:90px; width:728px;">
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1509569004297-3'); });
</script>
</div>
												<article id="post-115254" class="module single-post-module post-115254 post type-post status-publish format-standard has-post-thumbnail hentry category-trax et-has-post-format-content et_post_format-et-post-format-standard">
														<div class="post-header">
								<h1 class="entry-title">TRAX 06.11.20</h1>
								<div class="post-meta vcard">
									<p>Posted by <a href="https://pasadenaweekly.com/author/bliss-bowen/" class="url fn" title="Posts by Bliss Bowen" rel="author">Bliss Bowen</a> | <span class="updated">Jun 10, 2020</span> | <a class="comments-link" href="https://pasadenaweekly.com/trax-06-11-20/#comments">0 <span title="comment count" class="comment-bubble post-meta-icon"></span></a> | <span class="rating-stars" title="Rating: 0.00"><span class="post-meta-icon rating-star rating-star-empty rating-star-1"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-2"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-3"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-4"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-5"></span>
</span></p>
								</div>
							</div>
							
														<div class="post-thumbnail header">
								<img src="https://i2.wp.com/pasadenaweekly.com/wp-content/uploads/2020/06/Trax_web_061120.jpg?resize=800%2C533&amp;ssl=1" alt="TRAX 06.11.20" /><div class="featured_caption"></div>							</div>
							
														
							<div class="post-wrap">
															<div class="post-content entry-content">
									<div class='mailmunch-forms-before-post' style='display: none !important;'></div><p class="p1"><b>WYATT WADDELL, Fight! </b><b>(Rosebud Allday):</b> <span class="s2">****</span></p>
<p class="p2">In the expanding parade of raw songs emerging from historic protests marching across the country and globe, this soulful Chicagoan’s single stands out with its exuberant faith and focus. A smartly edited video swiftly garnered media attention and the song, released last week to digital platforms, piques curiosity about what Waddell could do with a lengthier project. “Starin’ officers in the face/ Sprayed with mace,” he sings over a rousing gospel choir and handclaps. “Stand up to fight/ It’s your moral right/ To stand against divide.”wyattwaddell.bandcamp.com</p>
<p class="p1"><b>LARKIN POE, <i>Self Made Man</i> </b><b>(Tricki-Woo):</b> <span class="s2">***</span></p>
<p class="p2">Self-producing sisters Rebecca and Megan Lovell lean harder into guitar-driven rock, braiding it with gospel elements and broadened subject matter in this follow-up to 2018’s slicker, Grammy-nominated “Venom &amp; Faith.” Titanic-themed stomper “God Moves on the Water,” first popularized by Blind Willie Johnson during the Depression, is augmented with Megan’s robust lap steel fills and new verses about the great San Francisco quake and contemporary struggles. The mood-shifting “Every Bird That Flies” further showcases how Megan textures and shapes their sound as Rebecca voices defiant spirit. “I got a plan up top and two strong hands,” she declares during the title track. “Lord have mercy, I’m a self-made man.” Other highlights: “Holy Ghost Fire,” “Ex-Con.” Larkinpoe.com</p>
<p class="p1"><b>BAB L’BLUZ, <i>Nayda!</i> </b><b>(RealWorld):</b> <span class="s2">****</span></p>
<p class="p2">The Moroccan-French quartet weave a percussive hybrid of gnawa and rock rhythms that’s funkier than West Africa’s more droning desert blues and less pop than the late Rachid Taha’s eclectic raï fusions. Frontwoman Yousra Mansour, who composed most tracks with guitarist/guembrist Brice Bottin, spiritedly occupies the role traditionally reserved for men in gnawa ceremonies, singing about freedom, healing, love, and government corruption in Moroccan-Arabic dialect. Highlights: a magnetic arrangement of Dimi Mint Abba and Khalifa Ould Eide’s “Waydelel,” with the awisha’s banjo-like lines undulating through the call-and-response chorus and bowed rebab (spiked fiddle); “Gnawa Beat”; and “Ila Mata,” a hypnotic call for justice and peace inspired by the words of Tunisian poet Anis Shoshan. realworldrecords.com/releases/nayda/</p>
<p class="p1"><b>LOUISE GOFFIN, <i>Two Different Movies</i> (Majority of One):</b> <span class="s2">***</span></p>
<p class="p2">Handsomely constructed melodies that evoke Laurel Canyon’s ’70s heyday as well as Goffin’s legendary parents (Carole King and Gerry Goffin) should make this 10-track set an ear-pleasing escape for pop fans. A sense of personal journey is underscored by the presence of a multigenerational crew of A-list players (including arranger Van Dyke Parks, keyboardist Benmont Tench, pedal steel master Greg Leisz) and the cover art (sketched by Joni Mitchell for an 11-year-old Goffin at a Carole King-James Taylor concert). Goffin gives poignant voice to commonly held yearnings with the title track, the dreamy “Safe Place to Land,” and especially “Simple Life”: “I want a simple life … I want to go outside, hang out with the birds and the trees.” louisegoffin.com</p>
<p class="p1"><b>ROLLING BLACKOUTS COASTAL FEVER, <i>Sideways to New Italy</i> (Sub Pop):</b> <span class="s2">***</span></p><div class='mailmunch-forms-in-post-middle' style='display: none !important;'></div>
<p class="p2">Guitars chime so brightly throughout the Australian rockers’ sophomore album that you can practically see sunlight shimmering on ocean waves. Guitarist-songwriters Fran Keaney, Tom Russo and Joe White exchange leads with crisp support from bassist Joe Russo and drummer Marcel Tussie, sketching harmonic promises in the air before uttering a word and animating beautiful aural pictures such as “Sunglasses at the Wedding” and “Falling Thunder.” Guitars ignite “The Second of the First,” while words unfortunately tarnish the labored “Beautiful Steven,” and with all the synth-stabbed dreams of “Cars in Space” and “Cameo” nostalgia comes a disquieting suspicion that gazing into the past while motoring up PCH appeals more than holding steady on the road ahead. rollingblackoutsband.com</p>
<p class="p1"><b>MADISON MCFERRIN, <i>Stay TF Inside — Live Loop Pack</i> (self-released): </b> <span class="s2">***</span><span class="s3"><b>½</b></span></p>
<p class="p2">A nimble a cappella soul artist, the Brooklyn vocalist offers blunt, pained reminders of the coronavirus pandemic’s enduring threat and human costs with these two smoothly crafted singles. McFerrin sweetens the sting of her no-nonsense declarations — “Stay TF Inside” and “[I Just Wanna] Hug My Mama” — with addictive hooks and silky harmonies repeatedly looped and layered with fingersnaps, to entrancing effect. A sonic reprieve and essential listening during this monumental summer. Madisonmcferrin.com</p>
<p class="p1"><b>MICHAEL MCDERMOTT, <i>What in the World…</i> (Pauper Sky): </b> <span class="s2">***</span><span class="s3"><b>½</b></span></p>
<p class="p2">The furious title track launches this emotional, rocking set, a hooky, Petty-esque broadside at political corruption, poverty, racism, police brutality, environmental devastation, the opioid epidemic, neo-Nazism, and “welfare for billionaires” (“Peter’s robbing Paul and they’re drinking with your paycheck”), themes revisited throughout the 12 tracks. McDermott’s lyrics are poetically barbed as usual and his tough-and-tender baritone’s in dynamic form as he alternates between acoustic-textured intimacy (“New York, Texas,” “Die With Me”), more grandly produced arrangements that suit his passionate subjects (“The Veils of Veronica,” the Charleston-inspired “Mother Emanuel”), and surprisingly happy interludes (the steel-buffed “The Things You Want”). michael-mcdermott.com</p>
<p class="p1"><b>TOMAR AND THE FCS, <i>Rise Above</i> (Splice): </b> <span class="s2">***</span><span class="s3"><b>½</b></span></p>
<p class="p2">“Often feels like times back in ’68 … and it’s not gonna change unless we feel the need/ Pain is pain regardless how you see it through/ You can’t forget about the next man and only focus on you.” Released at the beginning of the year, the Austin soul quintet’s sophomore album feels like worry-muting balm in this moment, winningly blending Stax-style grit, thumping grooves, and frontman Tomar Williams’ hopeful ebullience. Highlights: the horn-punched “Fine Time” (“You know my job just laid me off yesterday/ To be blindsided with all this news today”), “Innocence,” “Take Your Time.” thefcs.band</p>
<div class='mailmunch-forms-after-post' style='display: none !important;'></div>																	</div>
														</div>
														<div class="post-footer">
								<div class="social-icons ed-social-share-icons">
									<p class="share-title">Share:</p>
									
		
		
		
		
		<a href="http://www.facebook.com/sharer.php?u=https://pasadenaweekly.com/trax-06-11-20/&#038;t=TRAX%2006.11.20" class="social-share-link" title="Share &quot;TRAX 06.11.20&quot; via Facebook" data-network-name="facebook" data-share-title="TRAX 06.11.20" data-share-url="https://pasadenaweekly.com/trax-06-11-20/">
				<span class="et-extra-icon et-extra-icon-facebook et-extra-icon-background-hover" ></span>
			</a><a href="http://twitter.com/intent/tweet?text=TRAX%2006.11.20%20https://pasadenaweekly.com/trax-06-11-20/" class="social-share-link" title="Share &quot;TRAX 06.11.20&quot; via Twitter" data-network-name="twitter" data-share-title="TRAX 06.11.20" data-share-url="https://pasadenaweekly.com/trax-06-11-20/">
				<span class="et-extra-icon et-extra-icon-twitter et-extra-icon-background-hover" ></span>
			</a><a href="https://plus.google.com/share?url=https://pasadenaweekly.com/trax-06-11-20/&#038;t=TRAX%2006.11.20" class="social-share-link" title="Share &quot;TRAX 06.11.20&quot; via Google +" data-network-name="googleplus" data-share-title="TRAX 06.11.20" data-share-url="https://pasadenaweekly.com/trax-06-11-20/">
				<span class="et-extra-icon et-extra-icon-googleplus et-extra-icon-background-hover" ></span>
			</a><a href="#" class="social-share-link" title="Share &quot;TRAX 06.11.20&quot; via Email" data-network-name="basic_email" data-share-title="TRAX 06.11.20" data-share-url="https://pasadenaweekly.com/trax-06-11-20/">
				<span class="et-extra-icon et-extra-icon-basic_email et-extra-icon-background-hover" ></span>
			</a><a href="#" class="social-share-link" title="Share &quot;TRAX 06.11.20&quot; via Print" data-network-name="basic_print" data-share-title="TRAX 06.11.20" data-share-url="https://pasadenaweekly.com/trax-06-11-20/">
				<span class="et-extra-icon et-extra-icon-basic_print et-extra-icon-background-hover" ></span>
			</a>								</div>
																<div class="rating-stars">
									<p id="rate-title" class="rate-title">Rate:</p><div id="rating-stars"></div><input type="hidden" id="post_id" value="115254" />								</div>
																<style type="text/css" id="rating-stars">
									.post-footer .rating-stars #rated-stars img.star-on,
									.post-footer .rating-stars #rating-stars img.star-on {
										background-color: #1e73be;
									}
								</style>
							</div>

																				</article>

						<nav class="post-nav">
							<div class="nav-links clearfix">
								<div class="nav-link nav-link-prev">
									<a href="https://pasadenaweekly.com/trax-06-04-20/" rel="prev"><span class="button">Previous</span><span class="title">TRAX 06.04.20</span></a>								</div>
								<div class="nav-link nav-link-next">
									<a href="https://pasadenaweekly.com/cooking-up-community-commitment-at-altadenas-uedf-fish-chips/" rel="next"><span class="button">Next</span><span class="title">Cooking up community commitment at Altadena&#8217;s UEDF Fish &#038; Chips</span></a>								</div>
							</div>
						</nav>
						
										<!-- /1068269/LB2 -->
<div id="div-gpt-ad-1509569004297-1" style="height:90px; width:728px;">
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1509569004297-1'); });
</script>
</div>

				<!-- You can start editing here. -->

<section id="comment-wrap">
			<div id="comments" class="nocomments">
			 <!-- If comments are open, but there are no comments. -->

					</div>
					<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title"><span>Leave a reply</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/trax-06-11-20/#respond" style="display:none;">Cancel reply</a></small></h3><p class="must-log-in">You must be <a href="https://pasadenaweekly.com/wp-login.php?redirect_to=https%3A%2F%2Fpasadenaweekly.com%2Ftrax-06-11-20%2F">logged in</a> to post a comment.</p>	</div><!-- #respond -->
		</section>
			</div><!-- /.et_pb_extra_column.et_pb_extra_column_main -->

			<div class="et_pb_extra_column_sidebar">
	<div id="custom_html-4" class="widget_text et_pb_widget widget_custom_html"><h4 class="widgettitle">Subscribe Here</h4><div class="textwidget custom-html-widget"><center><img src="https://i0.wp.com/pasadenaweekly.com/wp-content/uploads/2020/05/pasadena-weekly-inbox2.jpg?resize=300%2C200&#038;ssl=1" width="300" height="200" alt="" data-recalc-dims="1"/></center><br>
<p>Subscribe to get Pasadena Weekly Digital Edition, emails and newsletters delivered weekly in your email inbox.</p>
<!-- Begin Mailchimp Signup Form -->
<div id="mc_embed_signup"><form id="mc-embedded-subscribe-form" class="validate" action="https://vcreporter.us19.list-manage.com/subscribe/post?u=0d04049df38fb8464a29c6623&amp;id=3eb451faf3" method="post" name="mc-embedded-subscribe-form" novalidate="" target="_blank">
<div class="mc-field-group"><label for="mce-EMAIL">Email Address Below</label>
<input id="mce-EMAIL" class="required email" name="EMAIL" type="email" value="" /></div>
<div id="mce-responses" class="clear">
<div id="mce-error-response" class="response" style="display: none;"></div>
<div id="mce-success-response" class="response" style="display: none;"></div>
</div>
<!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups-->
<div style="position: absolute; left: -5000px;" aria-hidden="true"><input tabindex="-1" name="b_0d04049df38fb8464a29c6623_3eb451faf3" type="text" value="" /></div>
&nbsp;
<br>
<input id="mc-embedded-subscribe" class="button" name="subscribe" type="submit" value="Subscribe" />

</form></div>
<!--End mc_embed_signup--><br><br>
<p>For information about our privacy practices, please visit our website at <a href="https://pasadenaweekly.com/privacy-policy/" target="_blank" rel="noopener noreferrer">https://pasadenaweekly.com/privacy-policy/</a><br><br>
By clicking to subscribe, you acknowledge that your information will be transferred to Mailchimp for processing. <a href="https://mailchimp.com/legal/" target="_blank" rel="noopener noreferrer">Learn more about Mailchimp's privacy practices here.</a></p></div></div> <!-- end .et_pb_widget --><div id="adrotate_widgets-9" class="et_pb_widget adrotate_widgets"><h4 class="widgettitle"> </h4><div class="g g-1"><div class="g-single a-84"><center><a class="gofollow" data-track="ODQsMSwxLDYw" href="pfcu.org"target="_blank"><img src="https://i0.wp.com/pasadenaweekly.com/wp-content/uploads/2020/06/PasFedCreditUnion_300x250-copy.png?ssl=1" /></a></center></div></div></div> <!-- end .et_pb_widget --><div id="search-3" class="et_pb_widget widget_search"><h4 class="widgettitle">Search PW</h4><form role="search" method="get" class="search-form" action="https://pasadenaweekly.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form></div> <!-- end .et_pb_widget --><p align='center'><!-- /1068269/Half_Page -->
<div id='div-gpt-ad-1509569004297-0' style='height:600px; width:300px;text-align:center;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1509569004297-0'); });
</script>
</div>
</p><div id="custom_html-3" class="widget_text et_pb_widget widget_custom_html"><h4 class="widgettitle">Digital Editions</h4><div class="textwidget custom-html-widget"><p><iframe id="bloxFrame" src="https://static.issuu.com/widgets/shelf/index.html?folderId=02bcd04f-47e9-4cdf-9b7a-7a4286718f54&amp;theme=theme3&amp;rows=1&amp;thumbSize=large&amp;roundedCorners=false&amp;showTitle=true&amp;showAuthor=false&amp;shadow=true&amp;effect3d=true" name="bloxFrame" width="100%" height="200px" frameborder="0" scrolling="auto"></iframe></p></div></div> <!-- end .et_pb_widget --><div id="adrotate_widgets-13" class="et_pb_widget adrotate_widgets"><h4 class="widgettitle"> </h4><div class="g g-9"><div class="g-single a-85"><center><a class="gofollow" data-track="ODUsOSwxLDYw" href="pfcu.org"target="_blank"><img src="https://i1.wp.com/pasadenaweekly.com/wp-content/uploads/2020/06/PasFedCreditUnion_300x600.png?ssl=1" /></a></center></div></div></div> <!-- end .et_pb_widget --><p align='center'><!-- /1068269/Square -->
<div id='div-gpt-ad-1509569004297-6' style='height:250px; width:300px;text-align:center;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1509569004297-6'); });
</script>
</div>
</p><div id="adrotate_widgets-10" class="et_pb_widget adrotate_widgets"><h4 class="widgettitle"> </h4><div class="g g-2"><div class="g-single a-79"><center><a class="gofollow" data-track="NzksMiwxLDYw" href="https://www.sciarc.edu/academics/summer-programs/design-immersion-days?utm_source=pasadenaweekly&utm_medium=banners&utm_campaign=SU20DID"><img src="https://i0.wp.com/pasadenaweekly.com/wp-content/uploads/2020/05/DID-300x250-1.jpg?ssl=1" /></a></center></div></div></div> <!-- end .et_pb_widget --><div id="ai1ec_agenda_widget-3" class="et_pb_widget widget_ai1ec_agenda_widget">

	<h4 class="widgettitle">Upcoming Events</h4>

<style>
<!--

-->
</style>
<div class="timely ai1ec-agenda-widget-view ai1ec-clearfix">

			<p class="ai1ec-no-results">
			There are no upcoming events.
		</p>
	 
			<div class="ai1ec-subscribe-buttons-widget">
							<a class="ai1ec-btn ai1ec-btn-default ai1ec-btn-xs ai1ec-pull-right
					ai1ec-calendar-link"
					href="https&#x3A;&#x2F;&#x2F;pasadenaweekly.com&#x2F;calendar-2&#x2F;">
					View Calendar
					<i class="ai1ec-fa ai1ec-fa-arrow-right"></i>
				</a>
			
					</div>
	 
</div>



</div> <!-- end .et_pb_widget --><p align='center'><!-- /1068269/SQ2 -->
<div id='div-gpt-ad-1509569004297-4' style='height:250px; width:300px;text-align:center;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1509569004297-4'); });
</script>
</div>
</p><div id="et-recent-comments-3" class="et_pb_widget widget_et_recent_comments"><h4 class="widgettitle">Recent Comments</h4><ul id="recentcomments" class="widget_list"><li class="recentcomments"><span class="author">SteveD</span>  <div class="post-title">on <a href="https://pasadenaweekly.com/letters-05-21-20/#comment-1822">Letters 05.21.20</a></div></li><li class="recentcomments"><span class="author">3sons4fun</span>  <div class="post-title">on <a href="https://pasadenaweekly.com/current-take-out-and-curbside-situation-is-a-menu-for-disaster-for-local-restaurants/#comment-1813">Current take-out and curbside situation is a menu for disaster for local restaurants</a></div></li><li class="recentcomments"><span class="author">cmaier31</span>  <div class="post-title">on <a href="https://pasadenaweekly.com/local-tenants-blow-the-whistle-on-landlord-who-turned-off-water-while-making-repairs-on-empty-units/#comment-1812">Local tenants blow the whistle on landlord who turned off water while making repairs on empty units</a></div></li></ul></div> <!-- end .et_pb_widget --><p align='center'><!-- /1068269/SQ3 -->
<div id='div-gpt-ad-1509569004297-5' style='height:250px; width:300px;text-align:center;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1509569004297-5'); });
</script>
</div>
</p><p align='right'><!-- /1068269/Half_Page02 -->
<div id='div-gpt-ad-1541632465426-0' style='height:600px; width:300px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1541632465426-0'); });
</script>
</div></p><div id="adrotate_widgets-11" class="et_pb_widget adrotate_widgets"><h4 class="widgettitle"> </h4><div class="g g-4"><div class="g-single a-54"><center><a class="gofollow" data-track="NTQsNCwxLDYw" href="https://www.smithbrothersrestaurants.com/"target="_blank"><img src="https://i0.wp.com/pasadenaweekly.com/wp-content/uploads/2020/04/PG-Ad.png?ssl=1" /></a></center></div></div></div> <!-- end .et_pb_widget --><div id="adrotate_widgets-12" class="et_pb_widget adrotate_widgets"><h4 class="widgettitle"> </h4><div class="g g-7"><div class="g-single a-87"><center>
  <p><a class="gofollow" data-track="ODcsNywxLDYw" href="https://www.andersonadvocates.com/abused-in-california/california-dioceses/archdiocese-of-los-angeles/" target="_blank"><img src="https://argonautnews.com/wp-content/uploads/2020/06/JAA20048_LA_Perp_300x250-5-1.jpg" alt="" width="300" height="250" border="0"/></a>
  </p>
  <center></div></div></div> <!-- end .et_pb_widget --></div>

		</div> <!-- #content-area -->
	</div> <!-- .container -->
	</div> <!-- #main-content -->

	
	<footer id="footer" class="footer_columns_2">
				<div id="footer-bottom">
			<div class="container">

				<!-- Footer Info -->
				<p id="footer-info">Designed by <a href="http://www.elegantthemes.com" title="Premium WordPress Themes">Elegant Themes</a> | Powered by <a href="http://www.wordpress.org">WordPress</a></p>

				<!-- Footer Navigation -->
								<div id="footer-nav">
					<ul id="footer-menu" class="bottom-nav"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-89365"><a href="https://pasadenaweekly.com/about/">About PW</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-89994"><a href="https://pasadenaweekly.wpengine.com/wp-login.php?action=register">Register for our Website</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-89995"><a href="https://pasadenaweekly.wpengine.com/wp-login.php">Login to our Website</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-89383"><a href="mailto:jon@pasadenaweekly.com">Feedback!</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-89367"><a href="https://pasadenaweekly.com/contact/">Contact Us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-89368"><a href="https://pasadenaweekly.com/advertising/">Advertising</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-89370"><a href="https://pasadenaweekly.com/advertising/legals/">Legal Advertising</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-90013"><a href="https://pasadenaweekly.com/pw-distribution-locations/">Where to Find Pasadena Weekly</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-89382"><a href="mailto:kevinu@pasadenaweekly.com">Send a Letter to the Editor</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-89373"><a href="http://www.vcreporter.com">Ventura County Reporter</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-89374"><a href="http://sdcitybeat.com">San Diego CityBeat</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-89375"><a href="http://argonautnews.com">The Argonaut</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-89376"><a href="http://lifeafter50.com">Life After 50</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-89377"><a href="http://ventanamonthly.com">Ventana Monthly</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-89378"><a href="http://arroyomonthly.com">Arroyo</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-89379"><a href="http://playavistadirect.com">Playa Vista Direct</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-89380"><a href="http://www.ireadculture.com">Culture</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-89366"><a href="https://pasadenaweekly.com/privacy-policy/">Privacy Policy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-90762"><a href="https://pasadenaweekly.com/careers/">Careers</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-89401"><a href="https://www.youtube.com/watch?v=oHg5SJYRHA0">Surprise!</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-101946"><a href="https://pasadenaweekly.com/category/specialissues/education-guide/">Schools</a></li>
</ul>						<ul class="et-extra-social-icons" style="">
																																								<li class="et-extra-social-icon facebook">
								<a href="https://www.facebook.com/PasadenaWeekly" class="et-extra-icon et-extra-icon-background-none et-extra-icon-facebook"></a>
							</li>
																																									<li class="et-extra-social-icon twitter">
								<a href="https://twitter.com/pasadenaweekly" class="et-extra-icon et-extra-icon-background-none et-extra-icon-twitter"></a>
							</li>
																																																																																																																																																																																<li class="et-extra-social-icon instagram">
								<a href="https://www.instagram.com/pasadenaweekly/" class="et-extra-icon et-extra-icon-background-none et-extra-icon-instagram"></a>
							</li>
																																																																																																																																																																																																																																																																																																																																																																																		</ul>
									</div> <!-- /#et-footer-nav -->
				<div class="g g-5"><div class="g-single a-78"><center><a href="https://www.sciarc.edu/academics/summer-programs/design-immersion-days?utm_source=pasadenaweekly&utm_medium=banners&utm_campaign=SU20DID"><img src="https://i2.wp.com/pasadenaweekly.com/wp-content/uploads/2020/05/DID-728x90-1.jpg?ssl=1" /></a></center></div></div>			</div>
		</div>
	</footer>
	</div> <!-- #page-container -->

			<span title="Back To Top" id="back_to_top"></span>
	
		<script type="text/javascript">
			</script>
	<script type='text/javascript' src='https://pasadenaweekly.com/wp-content/plugins/jetpack/_inc/build/photon/photon.min.js?ver=20130122'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var click_object = {"ajax_url":"https:\/\/pasadenaweekly.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://pasadenaweekly.com/wp-content/plugins/adrotate/library/jquery.adrotate.clicktracker.js'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=202024'></script>
<script type='text/javascript' src='https://pasadenaweekly.com/wp-includes/js/masonry.min.js?ver=3.3.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var EXTRA = {"images_uri":"https:\/\/pasadenaweekly.com\/wp-content\/themes\/Extra\/images\/","ajaxurl":"https:\/\/pasadenaweekly.com\/wp-admin\/admin-ajax.php","your_rating":"Your Rating:","item_in_cart_count":"%d Item in Cart","items_in_cart_count":"%d Items in Cart","item_count":"%d Item","items_count":"%d Items","rating_nonce":"7bce5225cd","timeline_nonce":"3c4ceab79b","blog_feed_nonce":"b5e6775f84","error":"There was a problem, please try again.","contact_error_name_required":"Name field cannot be empty.","contact_error_email_required":"Email field cannot be empty.","contact_error_email_invalid":"Please enter a valid email address.","is_ab_testing_active":"","is_cache_plugin_active":"no"};
var et_shortcodes_strings = {"previous":"Previous","next":"Next"};
var et_pb_custom = {"ajaxurl":"https:\/\/pasadenaweekly.com\/wp-admin\/admin-ajax.php","images_uri":"https:\/\/pasadenaweekly.com\/wp-content\/themes\/Extra\/images","builder_images_uri":"https:\/\/pasadenaweekly.com\/wp-content\/themes\/Extra\/includes\/builder\/images","et_frontend_nonce":"2fedf4c1c9","subscription_failed":"Please, check the fields below to make sure you entered the correct information.","et_ab_log_nonce":"dae189df79","fill_message":"Please, fill in the following fields:","contact_error_message":"Please, fix the following errors:","invalid":"Invalid email","captcha":"Captcha","prev":"Prev","previous":"Previous","next":"Next","wrong_captcha":"You entered the wrong number in captcha.","ignore_waypoints":"no","is_divi_theme_used":"","widget_search_selector":".widget_search","is_ab_testing_active":"","page_id":"115254","unique_test_id":"","ab_bounce_rate":"5","is_cache_plugin_active":"no","is_shortcode_tracking":"","tinymce_uri":""};
var et_pb_box_shadow_elements = [];
/* ]]> */
</script>
<script type='text/javascript' src='https://pasadenaweekly.com/wp-content/themes/Extra/scripts/scripts.min.js?ver=2.20.2'></script>
<script type='text/javascript' src='https://pasadenaweekly.com/wp-includes/js/comment-reply.min.js?ver=5.4.1'></script>
<script type='text/javascript' src='https://pasadenaweekly.com/wp-content/themes/Extra/core/admin/js/common.js?ver=3.20.2'></script>
<script type='text/javascript' src='https://pasadenaweekly.com/wp-includes/js/wp-embed.min.js?ver=5.4.1'></script>
<script type='text/javascript' src='https://pasadenaweekly.com/?ai1ec_render_js=common_frontend&#038;is_backend=false&#038;ver=2.6.1'></script>
<script type='text/javascript' src='https://stats.wp.com/e-202024.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:7.1.1',blog:'136211528',post:'115254',tz:'-7',srv:'pasadenaweekly.com'} ]);
	_stq.push([ 'clickTrackerInit', '136211528', '115254' ]);
</script>
</body>
</html>
